[tip] Norton Internet Security Configuration Guide
Marratech User Forum > Marratech > Marratech Client
This has been a recurring question for our support team, hopefully, this guide will help users with using Marratech Pro along with the Norton Personal Security firewall.

I did this installation on a new Dell Computer shipped with Windows XP and Norton Internet Security 2004. The only Norton Internet Security I have access to is in Swedish, so the translations are "best-effort". If I was able to learn Swedish, so can you :-D

Installing Marratech Pro 3.4
The installation went without a problem. The Norton Anti Virus suite warned me that a .msi file and a rt.jar file where being scanned. These warnings appear in the lower right corner, and may be hidden by another application. I had to press "OK" twice. The Marratech Pro installer "waited" for this to be complete before continuing.

Launching Marratech Pro
I then launched Marratech Pro. I got a warning saying that Marratech Pro would do a DNS access. I told Norton Personal Security to block everything. According to Norton, this is "Recommended".

This "blocking" blocks the session directory page from showing. It becomes blank. It is then impossible to surf with the viewer.

I try to launch a meeting from Internet Explorer. Marratech Pro starts but the meeting does not start. I see a link to http://sessiondirectory/abort/ in the Viewer, but it is empty.

Configuring Norton Personal Security

I then proceed to right clicking on the Norton Internet Security green globe in the system tray, next to the clock.

I click on "Personal Firewall". On the right, I see a link that says De-activate and Configure. De-activate is tempting... but let's try to configure it. :-)

After clicking the configure link, I chose the "Programs" tab on top. Here I see a list of software that the firewall has encountered. I see Marratech Pro in the list. It says that all internet access is blocked for Marratech Pro and that it is in the "common" category.

I select the Conference and Collaboration category for Marratech Pro and unblock the software by giving it complete Internet access and press OK. This gives Marratech Pro access to the ports it needs to communicate over the Internet, get web pages and accept Direct Calls.

Trying with Marratech Pro again
I then close the Norton Internet Security window. I press the "green" session directory button in the Marratech Pro viewer and now get the portal listing instead of a blank page.... seems promising :-)

I click on http://emeetingportal.com link and can then enter a room. Everything works.

I also tested launching from Internet Explorer and rebooting the machine to see if the setting was saved by the firewall. Everything seems to work.

Some Notes
[*] Marratech Pro is compatible with Dynamic State (also called Allow-Return) This means that the client expects an answer only after establishing a connection outwards. No allowing of "unexpected" external connections is required.
[*] You may encounter an extra warning after rebooting, it happened once out of 5 times for me. I selected "allow access", it then worked fine.
[*] For those even more technically interested, a document mentionning which ports to use and configure is available here: http://www.marratech.com/support/Firewall_Settings.pdf
Please share your experiences with Norton Firewall. If you have any tips and tricks... let us know!
Unfortunately, I've recently had significant issues with Norton Personal Security. Following these steps on a Windows XP system does not result in Marratech being able to join a meeting session. Under Configure/Programs Marratech is in the communication and collaboration category and full Internet access is enabled. I continually get the "firewall may be blocking" dialog even though other XP systems on the same network have no issues joining a meeting.

The Windows Firewall is OFF.

Log indicates that no attempt to access ports that initiate the session are successful. Any other likely culprits?
Norton can be very tricky at times.

The only other time we have seen such an issue was a customer in New York that had her network stack "hijacked" by spyware and needed to re-install her whole Windows XP.

Have you tried disabling Norton and / or switching it all off?

I have had two support cases with Norton FW, but don't have any solution on how to configurate it yet, so we disabled it while we used Marratech...
I did completely disable both virus checking and the personal firewall during the download. However, since this was someone else's productions system and I was on a completely open network, I was reluctant to leave too much off for too long. I did not try running Marratech with the firewall completely shut down. Perhaps we can do so later. This would tell us whether Norton Internet Security is the issue, but it doesn't provide a resolution that would make the customer comfortable, I think.
Hi Joe,

Nope, I would not leave a windows machine out on the net with no firewall either. However, you could follow these steps to safely find out if Norton Firewall is the culprit.

1. Unplug the computer's network cable.
2. Uninstall the norton firewall
3. enable the built in windows xp service pack 2 firewall
4. run Marratech Pro and see if it gets better.

Hope this helps,

Peter Cunningham
I use Norton Internet security (firewall plus antivirus) with Marratech on Microsoft XP and have no problem. When I first installed it I got a message Marratech Pro is attempting to connect by port X, do you want to allow or block. I clicked always allow and it works.

With MAC I use the same product. Similarly no problems although each time I launch Marratech (even before connecting to the server) I get a message saying Marratech is attempting to open this port which is currently blocked change or don't change. If you click change it allows the install.

I did not even have to go into the advanced options.

This is a "lo-fi" version of our main content. To view the full version with more information, formatting and images, please click here.
Invision Power Board © 2001-2009 Invision Power Services, Inc.